**Figure 4-62:** A schematic diagram of the finished model to illustrate the goal

**The Base**

The base consists of simple polygonal cubes representing timber and arranged to connect to each other. Keep in mind that in this exercise Interactive Creation for primitives is turned off (select Create ⇒ Polygon Primitives and make sure Interactive Creation is unchecked). Also, in the Perspective view, choose Shading ⇒ Wireframe On Shaded to turn on the wireframe lines while in Shaded mode to match the figures in this exercise.

**Creating the Base Objects**

To begin the catapult base, follow these steps:

1. Choose Create ⇒ Polygon Primitives ⇒ Cube to lay down your first cube. This will be for the two long, broad boards running alongside.

2. Scale the cube to 2.0 in X, 0.8 in Y, and 19.5 in Z. Move it off the center of the grid about 2 units to the right.

3. Now you’ll add some detail to the simple cube by beveling the sides, using either Modeling Toolkit or the traditional Bevel tool. Select the four edges running on top of the board. In the main menu bar, select Edit Mesh ⇒ Bevel. Set Fraction to 0.2 and Segments to 2. **Figure 4-63** shows the resulting board.
**Figure 4-63:** Create a bevel for the baseboard object.

4. Select the remaining edges on the board, bevel them to a fraction of **0.3**, and set Segments to **2**. See **Figure 4-64**.

**Figure 4-64:** Beveling the bottom edges

Beveling the edges of your models can be an important detail. Light will pick up edges much better when they are beveled, even slightly. Perfect 90-degree corners can look too much like CG models and not real objects.

5. Select the board and choose Edit ⇒ Duplicate to place a copy of the board exactly where the original is in the scene. The new duplicated board is already selected for you, so just move the copy about 4 units to the left. You should now have something similar to **Figure 4-65** (top).
Figure 4-65: The long boards at the base (top) and the platform board in place (bottom)

6. Now for the cross braces and platform. Create a poly cube and scale it to 7.25 in X, 0.6 in Y, and 3.25 in Z. Place this platform on top of the two beams, at the end of the catapult’s base.

7. With the first board that you beveled, you had a different bevel for the top edges than for the bottom and sides. For this board, you’ll have the same bevel width for all its edges. Select the cube in object mode (not the edges as before) and choose Edit Mesh ⇒ Bevel or
click the Bevel icon in Modeling Toolkit. Set Fraction to 0.2 and Segments to 2. **Figure 4-65** (bottom) shows the platform board in place and beveled.

8. Create a cube for the first of the top two cross braces and scale it 6.5 in X, 0.6 in Y, and 1.2 in Z. Place it on top of the beams at the head of the base and bevel this cube exactly as in the previous step.

9. Duplicate the cube and move the copy about a third of the way down toward the end (Figure 4-66).

**Figure 4-66:** Cross bracing the base

**Using Booleans**

You're going to add some detail as you go along, namely, the large screws that hold the timber together. The screws will basically be slotted screw heads placed at the intersection of the pieces. In this section, you will use Booleans to help create the screw heads.

Booleans are impressive operations that allow you to, among other things, cut holes or shapes in a mesh fairly easily. Basically, a Boolean is a geometric operation that creates a shape from the addition of two shapes (Union), the subtraction of one shape from another (Difference), or the common intersection of two shapes (Intersection).

Be forewarned, however, that Boolean operations can be problematic. Sometimes you get a result that is wrong—or, even worse, the entire mesh disappears and you have to undo. Use Booleans sparingly and only on a mesh that is clean and prepared. You've cleaned and prepped your panel mesh, so there should be no problems. (Actually, there will be a problem, but that's half the fun of learning, so let's get on with it.)

First, you need to create the rounded screw head.
1. Create a polygonal sphere (Create ⇒ Polygon Primitives ⇒ Sphere) and move it from the origin off to the side in the X-axis of the base model. Scale the sphere down to 0.15 in XYZ.

2. With the sphere still selected, switch to the front view and press F to frame. RMB+click the sphere and select Face from the marking menu (Figure 4-67). Select the bottom half of the sphere’s faces and press Delete on your keyboard to make a hemisphere (Figure 4-68).

**Figure 4-67:** Use the marking menu to set the selection to Face.
**Figure 4-68:** Delete the bottom half of the faces.

3. RMB+click the hemisphere and select Object Mode from the marking menu; this exits face selection mode. Create a poly cube and scale it to 0.4, 0.1, 0.04. Place it over the hemisphere as shown in **Figure 4-69**.
**Figure 4-69:** Place the scaled cube over the screw head.

Now you have both objects that you need for a Boolean operation, and they are placed properly to create a slot in the top of the screw head.

![Boolean Operation](image)

**Figure 4-70:** Selecting a Difference Boolean

4. Select the hemisphere and then the cube set into it. Select Mesh ⇒ Booleans ⇒ Difference (**Figure 4-70**). The cube disappears, and the screw head is left with a slot in the top. However, the screw head appears hollow. In the floating menu of the Boolean operation, set the Classification attribute to Edge from Normal, and your screw head will become solid, as shown in **Figure 4-71**.
**Figure 4-71:** The screw head is slotted.

**Ngons!**

If you take a good close look at the screw head, especially where the slot is, you will notice faces that have more than four sides, which makes them Ngons. As I noted earlier in the chapter, faces that have more than four edges may be problematic with further modeling or rendering. This simple screw head most likely will not pose any problems in the application here, but let's go over how to prevent any problems early on. You will select the potential problem faces (those around the slot) and triangulate them.

1. Select all the faces around the slot, as shown in Figure 4-72 (left). Choose Mesh → Triangulate. This is the easiest and fastest way to subdivide these faces from being Ngons without having to use the Multi-Cut tool to manually fix them. And although it may not look as clean as before (Figure 4-72, right), the geometry is clean and will not be a potential problem like Ngons may be.
Figure 4-72: Select the faces around the slot (left) and triangulate them (right).

2. Select the screw head and choose Edit ⇒ Delete By Type ⇒ History. This cleans out any history on the object now that you're satisfied with it.

3. Notice that the screw head's pivot point is at the origin. With the object selected, choose Modify ⇒ Center Pivot.

4. Name the object **ScrewHead** and position it at one of the intersections of the boards you've built so far.

5. Duplicate that first screw head and place the copies one by one at all the other intersections on the base, as shown in Figure 4-73. These are pretty big screws, huh? For this simple catapult, they'll do fine. The workflow to make more realistic screws is the same if you want to make this again with more realism and scale.
Figure 4-73: Place the screw heads on the base and organize your scene.

6. Now take the objects in the scene and group them into a logical order, as shown in the Outliner in Figure 4-73.

Save your file and compare it to catapult_v1.mb in the Catapult project from the companion website to see what the completed base should look like.

The time you spend keeping your scene objects organized now will pay off later when you animate the catapult in Chapter 8.

The Winch Baseboards

Next to model for the base are the bars that hold the winch assembly to the base. Refer to the sketch of the catapult (Figure 4-60, earlier) to refresh yourself on the layout of the catapult and its pieces. Follow these steps:

1. Create two long, narrow, beveled poly cubes for the baseboards of the winch and position them across the top two side braces. Put a couple of screws on the middle crossbeam (see Figure 4-74).
2. For the brackets that hold down the winch, create a small poly cube and move it off to the side of the base to get it out of the way. Scale the cube to 0.5, 0.3, 0.45. Select the side face and click the Extrude button in the Modeling Toolkit panel. Use 0.8 for the Thickness attribute, as shown in Figure 4-75.
**Figure 4-75:** Use Modeling Toolkit to extrude the face.

3. Select the top face of the original cube and use Modeling Toolkit to extrude it to a Thickness setting of **1.54** to take it up to an \( L \) shape. Select the two inside vertices on the top of the \( L \) and move them up to create about a 45-degree angle at the tip, as shown in **Figure 4-76**.
Figure 4-76: Extrude the top to create an L shape; then move the vertices up to angle the top of the L.

4. Select that angled face and select Extrude in Modeling Toolkit or choose Edit Mesh ⇒ Extrude for an extrusion. Click the cyan-colored switch icon above the Extrude manipulator (shown next to the cursor in Figure 4-77, left). This will switch the extrusion axis (Figure 4-77, center) so you can pull the faces out straight and not angled up. Then grab the Z Move manipulator and manually pull the extrusion out about 0.75 units.
Figure 4-77: Click the switch icon (left) to switch the axis of extrusion (center). Rotate and scale the face to square it (right).

5. Press E to exit the Extrude tool and enter Rotate. Select the end face and rotate it to make it flat vertically and scale it down in Y-axis to prevent it from flaring upward (Figure 4-77, right). It is important to make the face vertical because it affects step 6.

6. This shape forms half of the braces you need. To create the other half, select the face shown in Figure 4-78 (left) and delete it (press Delete). Enter Object mode, select the mesh, and choose Mesh ⇒ Mirror Geometry ☐. Set Mirror Direction to -Z, and leave the options as shown in Figure 4-78 (right). Click Mirror, and you will have a full bracket.

If your face is not rotated to be vertical in the previous step, you may see a gap between the two sides of the bracket. In this case, select the vertices on both sides of this gap and use Edit Mesh ⇒ Merge to Center to seal the bracket into one piece.

Figure 4-78: Delete the face (left) and set the Mirror Geometry options (right).

7. Name the object bracket and move it on top of one of the baseboards for the winch; then place a duplicated screw head on the flanges of the bracket. Group the bracket and screw heads together by selecting them and choosing Edit ⇒ Group; call the group bracketGroup.

8. Duplicate bracketGroup and move the copy to the other baseboard, as shown in Figure 4-79. Organize your scene as shown in the Outliner in Figure 4-79.
**Figure 4-79:** The winch’s base completed

**The Ground Spikes**

The last items you need for the base are the spikes that secure the base into the ground at the foot of the catapult. Follow these steps:

1. Duplicate a bracket group and name it `bracketGroupCOPY`. Remove the group from its current hierarchy (the baseboard group) by MMB+dragging it to another location in the Outliner (see **Figure 4-80**). Center its pivot (Modify => Center Pivot).
Figure 4-80: MMB-dragging the duplicated bracketGroup to another location in the Outliner removes the group from the Winch_baseboard1 group.

2. Move the bracket to the other side of the base. Rotate it on its side, scale it to about half its size in all three axes, and place it as shown in Figure 4-81 (left). Select the top vertices and move them closer to the base, as shown in Figure 4-81 (right).

3. Now for the spike itself. Create a poly cube and position and scale it to fit through the bracket. Scale the spike cube to about 3.5 in
the Y-axis. Select the bottom face of the spike cube and choose Edit Mesh ⇒ Extrude or use Modeling Toolkit. In the floating panel, set Thickness to 0.5 and Offset to 0.15, as shown in Figure 4-82. You may have to adjust the scale of the cube and or the Offset value of the extrusion to get your spike to resemble the one in the book since the exact scaling of the cube you just created may be different than what I've done here.

Figure 4-81: Position and scale the bracket assembly for the ground spikes (left). Move the vertices to reduce the depth (right).
Figure 4-8a: Creating the spike

4. Bevel the spike if you’d like. Then select spike and bracketGroupCOPY and group them together, calling the new group stakeGroup; center its pivot.

5. Duplicate the stake group and move and rotate it 180 degrees in the Y-axis to fit to the other side of the base. Organize everything into a parent Catapult group (see Figure 4-8b) and save your scene as a new version.
**Figure 4-83:** The completed base

The scene file `catapult_v2.mb` in the Catapult project from the companion website has the completed base for comparison.

**The Wheels**

What's a catapult if you can't move it around to vanquish your enemies? So now, you will create the wheels. Follow these steps:

1. First is the axle. Create a polygon cylinder (Create ➔ Polygon Primitives ➔ Cylinder) and then scale, rotate, and place it as shown in **Figure 4-84** to be the rear axle.
2. Duplicate one of the stake assembly’s bracket groups (bracketGroupCOPY) two times; then move and scale each of the two copies to hold the axle on either side. Move down the top vertices of the bracket to make the bracket fit snugly around the axle as needed, as in Figure 4-85. Remember to move the duplicated brackets out of their existing hierarchy in the stakeGroups. Group both the axle brackets together and name the group **Axle_Brackets**. You are not grouping the brackets with the axle cylinder. Keep them separate. You’ll organize the hierarchy better a little later.
**Figure 4-85:** Place brackets to hold the rear axle and adjust the vertices to make it fit.

3. To make the axle a little more interesting, let's add a taper at the ends. You will insert new edges around the ends by using Insert Edge Loop, which will be much faster than the Multi-Cut tool in this case. Select the rear axle cylinder and choose Mesh Tools ⇒ Insert Edge Loop. Your cursor turns into a triangle. Select one of the horizontal edges on the cylinder toward one end, as shown in Figure 4-86. A dashed line will appear running vertically around the cylinder. Drag the cursor to place the dashed line as shown in Figure 4-86 and release the mouse button to commit the new edges to that location. Repeat the procedure for the other side.

4. Select the end cap faces and scale them down on each side of the axle cylinder, as shown in Figure 4-87, to create tapered ends. Name the cylinder **rearAxle.** Now you're ready for the rear wheels.
**Figure 4-86**: Insert an edge loop around the end of the cylinder.
5. To model a wheel, first you'll use NURBS curves to lay out a profile to revolve. Go into the front view. Choose Create ⇒ Curve Tools ⇒ CV Curve Tool and select 1 Linear for Curve Degree. Since the wheel's profile will have no smooth curves, you can create a linear CV curve like that in Figure 4-88, laying down CVs clockwise starting in the top-left corner, as shown; otherwise, your wheel may become inside-out and flat black in step 7. This is something that can easily be fixed in step 7 as well. It's important for the design to create three spans for the top part of the curve. Place the pivot point (hold down the D key or press Insert on a PC or Home on a Mac) about three-quarters of a unit below the curve, as shown. This curve will be the profile of the front of the wheel.
Figure 4-88: The profile curve for the wheel is drawn clockwise in the front view panel.

6. Place the profile above the rear axle. To make sure the pivot point for the profile lines up with the center of the axle, turn on Snap To Points (a.k.a. Point Snap) and press and hold down D to move the pivot. Snap the pivot to the center of the axle, as shown in Figure 4-89. Turn off Point Snap.

7. Select the curve and revolve it by choosing Surfaces ⇒ Revolve □ (Figure 4-90). In the option box, set Axis Preset to X to make it revolve correctly. Change Segments from the default 8 to 20 to give a smoother wheel. Set Output Geometry to Polygons and set Tessellation Method to Control Points. This will create the edges of the faces along the CV points on the curve. Click Revolve, and there it is (Figure 4-91).

If for some reason your wheel object displays as black, this means the surface is inside out (the normals are reversed). With the wheel object selected, in the Modeling menu set, select Mesh Display ⇒ Reverse under the Normals menu heading.
**Figure 4-89:** The profile curve is in place for the rear wheel.

**Figure 4-90:** Selecting the Revolve surface operation

8. Select the wheel object and bevel it. With the wheel still selected, delete the history and the original NURBS curve since you won't need
either again.

9. Add some detail to the wheel. Duplicate a screw head and remove the copy from whatever group it was in by MMB+dragging it out of the current group in the Outliner. Arrange a few of the screw heads around the front face of the wheel.

10. Add a couple of braces on the front of the wheel above and below the wheel's middle hole with two thin, stretched, and beveled poly cubes, with screws on either side (as shown in Figure 4-92). Again, make sure to remove the duplicated screw heads from whatever group you got them from.

11. Select all the objects of the wheel, group them together by pressing Ctrl+G, and call the group wheel. Center the wheel group's pivot point by choosing Modify → Center Pivot.

Figure 4-91: The wheel revolved
Figure 4-92: Adding detail to the wheel

2. Adding studs to the wheel makes for better traction when moving the catapult through mud and also for a cooler-looking catapult. To create all the studs at once, grab every other middle face along the outside of the wheel and extrude them with a Thickness of 0.3 and an Offset of 0.1, as shown in Figure 4-93. If your studs are extruding inward into the wheel, then simply use a Thickness value of 0.3 instead of -0.3.
**Figure 4-03:** Extrude studs for the wheel.

3. Copy the wheel group and rotate it 180 degrees in the Y-axis to create the other rear wheel for the other side. Position it on the other side of the rear axle.

4. Group the two wheels with the rear axle and call the new group node `Rear_Wheel`.

5. Select the `Rear_Wheel` node and the `Axle_Brackets` group node and duplicate them by choosing Edit ➔ Duplicate or by pressing the
hotkey Ctrl+D. Move the objects to the foot of the catapult for the front wheels. Rename the wheel group node **Front_Wheel**.

6. Add the new axle bracket and wheel group nodes to the Catapult top node by MMB+dragging them onto the Catapult node in the Outliner; save your scene. **Figure 4-94** shows the positions and Outliner hierarchy of the wheels.

![Outliner](image)

**Figure 4-94:** The wheels and brackets are positioned, and the hierarchy is organized.

The file **catapult_v3.mb** in the Catapult project from the companion website reflects the finished wheels and base.

**The Winch Assembly**

To be able to pull the catapult arm down to cock it to fire a projectile, you'll need the winch assembly to wind a rope that connects to the arm to wind it down into firing position. Since animating a rope can be a rather involved and advanced technique, the catapult will not actually be built with a rope. To build the winch assembly, follow these steps:

1. The first part of the winch is the pulley around which the rope winds. In the front view panel, create a profile curve for extrusion as you did with the wheel that looks more or less like the profile curve in **Figure 4-95**, drawn clockwise starting with the left side of the profile curve. In this figure, the first CV of the profile curve is on the left end of the curve. Place the pivot point of the curve at that first CV. Revolve the curve around the X-axis with only 12 segments (as opposed to the wheel’s 20). Center its pivot, and you have the pulley.

   If your pulley object is black, its surface is likely inside out (reversed normals), depending on how you created the profile curve in
this step. In this case, select the pulley object and select Mesh Display ⇒ Reverse under the Normals menu heading.

*Figure 4-95:* Create a profile curve and revolve it to create the object shown below the profile curve.

2. Position the pulley at the rear of the catapult, placing the brackets in the grooves (see *Figure 4-96*).
Figure 4-96: Place the pulley.

3. Now you'll need some sort of geared wheel and handle to crank the pulley. Create a poly cylinder and rotate it so it's on its side like one of the wheels. Scale it to a squat disk with scale values of 1.4 in the X- and Z-axes and 0.4 in the Y-axis. Select the disk and bevel it.

4. Off on the side of your scene, create another poly cylinder, and rotate it to its side as well. Scale it to be a long, thin stick. You'll use
this as the first of eight gear teeth for the wheel. Position it at the top of the wheel, as shown in Figure 4-97. Click the Snap To Points icon in the Status line ( ) and snap the pivot point (press D to move the pivot) to the center of the wheel. Turn off Snap To Points.

**Figure 4-97:** Making a gear wheel

5. Instead of duplicating the gear tooth and positioning it seven more times individually, you'll use the array capabilities of the Duplicate Special tool. Select the tooth and choose Edit ⇒ Duplicate Special 2. In the option box, set Rotate to 45 in the X-axis, and set Number Of Copies to 7. Since the pivot for the tooth is at the center of the wheel, as soon as you click the Duplicate Special button, Maya places seven copies around the wheel at 45-degree intervals (Figure 4-98).
Figure 4-98: Eight gear teeth in place

6. Now for the handle. Create a poly cube with enough segments for you to adjust vertices and faces to match the handle shown in Figure 4-99. Create cylinders for the crank axle and handle and place them as shown. Group all the parts together and snap the pivot point to the center of the gear wheel disk. Name the group handle. You can bevel the handle if you want.
Figure 4-99: Use two cylinders and a poly cube to create the handle shapes.

7. Group the geometry together, call the object **Turn_Wheel**, and center its pivot. Place it at the end of the pulley. Place a copy (rotated 180 degrees) on the other side of the pulley. **Figure 4-100** shows the placement.
**Figure 4-100:** Place the turn wheels.

8. Now you'll need gear teeth on the pulley cylinder shape. Create a poly cylinder to be a long, thin tube like the gear teeth and position it at the end of the pulley. Place it so that it is in between two of the turning wheel gear teeth. Place the pivot at the center of the pulley using Snap To Points.

9. Duplicate the new tooth seven times around the pulley at 45-degree intervals with Duplicate Special.

10. Make a copy of each of those eight teeth and move the copies to the other side of the pulley for the other gear. Group the pulley and turning wheels together and name the object **Winch**, as shown in **Figure 4-101**. Center the pivot.
Figure 4-101: The winch gears and handles

1. Using a couple of poly cubes that you shape by moving vertices, make a winch arm on either side to brace the winch to the catapult. Bevel the shapes when you are happy with their shapes. Place the braces between the crank handle and the turning wheel on both sides, and bolt them to the catapult's base, as shown in Figure 4-102. Group them and add them to the hierarchy as shown. Save your scene file.

To verify your work up to this point, compare it to catapult_v4.mb in the Catapult project from the companion website.
Figure 4-102: The assembled winch

The Arm

OK, now I'm kicking you out of the nest to fly on your own! Try creating the arm (see Figure 4-103), without step-by-step instruction, using all the techniques you've learned and the following hints and diagrams:

- Create the intricate-looking arm with face extrusions. That's all you'll need for the arm geometry. Follow Figure 4-104 for subdivision positions to make the extrusions work correctly.
Figure 4-103: The catapult arm assembly
Figure 4-104: Follow the subdivisions on your model.

- Duplicate and place screw heads around the basket assembly, as shown in Figure 4-105.
**Figure 4-105:** Place screw heads around the basket arms.

- Create the straps for the basket with poly cubes. It's easier than it looks. You'll just need to create and extrude the cubes with enough subdivisions to allow you to bend them to weave them together, as shown in Figure 4-106. The ends of the straps wrap around the arm's basket with extrusions.
Figure 4-106: Basket straps

- Create the hinge for the arm with a couple of duplicated brackets and a cylinder.
- Create the arm's stand with multiple extrusions from a cube. Follow the subdivisions in Figure 4-107 for reference.
**Figure 4-107**: Follow the subdivisions on the arm stand.

- Bevel the parts you feel could use some nice edging, including the arm and stand pieces.
- Group the objects together and add their groups to the Catapult node.

When you've finished, save your scene file and compare it to catapult_v5.mb in the Catapult project from the companion website. **Figure 4-108** shows the finished catapult.
Figure 4-108: The completed catapult

Summary

In this chapter, you learned about the basic modeling workflows with Maya and Modeling Toolkit and how best to approach a model. This chapter dealt with polygon modeling and covered several polygon creation and editing tools, as well as several polygon subdivision tools. You put those tools to good use by building a cartoon hand and smoothing it out, as well as making a model of an old-fashioned catapult using traditional Maya workflows as well as new Modeling Toolkit workflows. The latter exercise stressed the importance of putting a model together step-by-step and understanding how elements join together to form a whole in a proper hierarchy. You’ll have a chance to make another model of that kind in Chapter 6, when you create a toy airplane that is used to light and render later in the book.

Complex models become much easier to create when you recognize how to deconstruct them into their base components. You can divide even simple objects into more easily managed segments from which you can create a model.

The art of modeling with polygons is like anything else in Maya: Your technique and workflow will improve with practice and time. It’s less important to know all the tricks of the trade than it is to know how to approach a model and fit it into a wireframe mesh.